Transport Museum, Wythall Monday 28 August 2017 part one.

Discussions about the Bus and Coach Preservation scene for Midland "Red" Motor Services and related companies.
Post Reply
TimBrown
Posts: 194
Joined: 05:59 Monday 4th July 2016
Location: Worcester

Transport Museum, Wythall Monday 28 August 2017 part one.

Post by TimBrown » 20:33 Monday 28th August 2017

Here are photos of some of the Midland Red vehicles on show at the Transport Museum, Wythall on Monday 28 August, 2017. I think one of regular contributors will be pleased that 6015 was displayed in the sunshine today!
28 August 2017 Wythall 149.jpg
28 August 2017 Wythall 125.jpg
28 August 2017 Wythall 128.jpg
28 August 2017 Wythall 146.jpg
28 August 2017 Wythall 129.jpg
28 August 2017 Wythall 130.jpg
28 August 2017 Wythall 131.jpg
28 August 2017 Wythall 148.jpg

DD12
Posts: 341
Joined: 19:49 Monday 4th July 2016

Re: Transport Museum, Wythall Monday 28 August 2017 part one.

Post by DD12 » 21:29 Monday 28th August 2017

Thanks Tim ! - Great photos !

It's a long time since I've seen a side (profile ?) photo of a DD12 -

Beautiful, isn't it !! :)

(P.S. Did I miss a chance to ride on the LD8 again ? )

TimBrown
Posts: 194
Joined: 05:59 Monday 4th July 2016
Location: Worcester

Re: Transport Museum, Wythall Monday 28 August 2017 part one.

Post by TimBrown » 05:52 Tuesday 29th August 2017

DD12 wrote:
21:29 Monday 28th August 2017

It's a long time since I've seen a side (profile ?) photo of a DD12 -

Beautiful, isn't it !! :)

(P.S. Did I miss a chance to ride on the LD8 again ? )
6015 I don't know about beautiful (beauty is in the eye of the beholder), but this Anglo-Scottish confection did look good languishing in the sunshine. Did the temperature hit the 80F mark, it certainly felt very hot queueing in the sun for the various rides!

Yes, the LD8 4031 was out working to The Maypole and back, looking and sounding very good.

User avatar
AdamH
Posts: 755
Joined: 12:17 Sunday 3rd July 2016
Location: Worcester

Re: Transport Museum, Wythall Monday 28 August 2017 part one.

Post by AdamH » 12:56 Wednesday 30th August 2017

Thanks for the photos of 6015. I've never managed to get a photo of that vehicle outside as every time I have visited the museum it has been parked indoors. I will shortly be using one of your photos for the main website library if you don't mind?

I was at the museum this morning with a few colleagues and I did get a chance to see 6015 running and had a quick ride to the bottom gate and back. Also got my first ever ride on a BMMO S16. It was standing room only on the DD12, not because the bus was full but because it hasn't been cleaned inside for quite some time and I didn't want to sit down!! :lol:

So did I finally manage to get a good outdoors photo of the DD12? Yes and no. Got some outdoor photos but it was dark and raining so they are not the best. Pictures of the inside taken on my mobile are attached.
Attachments
IMG_6357.JPG
IMG_6356.JPG
IMG_6354.JPG
IMG_6353.JPG

DD12
Posts: 341
Joined: 19:49 Monday 4th July 2016

Re: Transport Museum, Wythall Monday 28 August 2017 part one.

Post by DD12 » 15:29 Wednesday 30th August 2017

I am "somewhat envious !", Adam, that you have taken that short ride on 6015 -
- and surprised that the engine actually worked (I have heard it needs rebuilding) !

The last ride (probably) that I took on a DD12, was on a freshly painted 6032 GHA432D, in the early 80's, at an open-day at Swadlincote garage !

User avatar
AdamH
Posts: 755
Joined: 12:17 Sunday 3rd July 2016
Location: Worcester

Re: Transport Museum, Wythall Monday 28 August 2017 part one.

Post by AdamH » 15:53 Wednesday 30th August 2017

Before today I was also under the impression it was a non-runner, however when connected to an external battery pack it started first time. There was quite a lot of smoke, but I've seen service buses with worse! It was a bit rattly though.

https://youtu.be/MPY8Ck74kCo

DD12
Posts: 341
Joined: 19:49 Monday 4th July 2016

Re: Transport Museum, Wythall Monday 28 August 2017 part one.

Post by DD12 » 11:45 Wednesday 13th September 2017

AdamH wrote:
15:53 Wednesday 30th August 2017
Before today I was also under the impression it was a non-runner, however when connected to an external battery pack it started first time. There was quite a lot of smoke, but I've seen service buses with worse! It was a bit rattly though.

https://youtu.be/MPY8Ck74kCo
Thanks very much for that video Adam -
it's the first video I've ever seen of a DD12 !! :)

Post Reply

Return to “Preservation”

Who is online

Users browsing this forum: No registered users and 1 guest